Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2025 - 20:00 GMT
Scheduled
Please be aware that we will be performing essential maintenance tonight on Schoolcomms & School Gateway between 20:00 - 00:00. During this time, you may experience disruptions to the service. If so, please try again later. We apologise for any inconvenience caused and appreciate your patience.
Posted Mar 21, 2025 - 15:35 GMT
This scheduled maintenance affected: Schoolcomms and School Gateway.